Buy Game Flag
Before using the forum please read and make sure you agree to our Forum Rules. Forum Rules

Home Forums General Discussion Bossa – Your Response to this Game-breaking Bug has been Unacceptably Terrible

This topic contains 71 replies, has 33 voices, and was last updated by  Atreties 8 hours, 44 minutes ago.

Viewing 15 posts - 1 through 15 (of 74 total)
Author
Posts
#94656
Atreties
Participant

Edit: Bug fixed.

Bugs happen, especially in betas of games. Having a bug pop up is not a problem at all. Having a game-breaking bug pop up is more annoying, but even that can be fine, as long as it is either dealt with in a timely manner, or if the community is communicated with sufficiently about the bug.

A game breaking full-ship-deletion bug has existed in the game for over a week and nothing has been done about it, and no communication has been given about it. Most of your endgame players have stopped playing until the bug is fixed.

Note – this bug does not only happen during combat. Any time anything knocked off of their ship, there seems to be a chance for deletion. This means that anyone doing a stormwall could simply delete. Also, as shown in the Vexus Aluminum Part 1 below, it is possible to simply fly around, hit something invisible, and then delete. Also shown in the Vexus Titanium example below, you can simply log your ship in, take damage from the login, and delete.

– You can lose a single object in combat and delete
– You can login and simply delete
– You can be flying around normally and simply delete
– You can be doing a routine stormwall and delete
– A pack of mantas can kill a small panel and you can delete
– You can be doing anything, any time, and you can just delete.

The devs have known about this for over a week, not fixed it, not reverted the broken patch, and not communicated about this issue at all Edit: in any meaningful way.

Examples of the bug occurring:
Vexus Titanium Ship –
https://clips.twitch.tv/GrotesqueOpenVanillaSeemsGood

Vexus Aluminum Ship (Parts 1 and 2)-
https://clips.twitch.tv/TacitFairConsoleRaccAttack
https://clips.twitch.tv/CreativeDeterminedSalmonPeanutButterJellyTime

Vexus Bronze Battleship –
https://clips.twitch.tv/ResilientSweetSandstormChocolateRain

Vexus Deleting Eranok’s Ship –
https://clips.twitch.tv/CleverFaithfulPartridgeFailFish

Vexus Deleting Derelict –
https://clips.twitch.tv/BitterTawdryCheeseBuddhaBar

The_Chili US ship –
https://clips.twitch.tv/ArbitraryWealthyPterodactylTebowing

The_Chili EU ship –
https://clips.twitch.tv/RelatedBillowingCatNotLikeThis

The Chili 4th Ship –

.
.
I could scour dozens of other streams and videos and pick out dozens more examples. It’s happening on a massive scale, with literally hundreds of hours of resource gathering and ship building getting wasted.

Bossa: It’s been over a week. Fix it, revert the patch, or ACTUALLY COMMUNICATE IN AN EFFECTIVE WAY WITH YOUR PLAYERS FOR ONCE.

#94658
Sky Silverwing
Participant

Oh wow, I had no idea a bug like that existed! I’ve been sailing around on my raft with no issues so far. 😮

I haven’t been attacked by anything though.

#94659
Thuntomite Stew
Participant

As Atreties said, this has gone on for way to long. To further compound the issue, you are expecting to release keys tomorrow. With it being a key release day, you are going to witness a large number of these noobs simply deleting followed by possibly a refund.

Us veterans of the game may have the will and fortitude to deal with it and carry on playing but others do not. After the first few days of constant reports of deletion the patch should have been reverted, it is so prevalent right now.

Nine times out of ten in a fight a ship is deleting at this point. Bossa confirmed they had found the reason for the issue and were working on a fix within 2 days of it first occurring, I received this information directly as well as others. We are now a week or so in, as above once a cause was confirmed the patch should of been reverted and testing and hotfixing should of been done in house without affecting the live server.

This is having a dramatic affect on the player base right now and it is being handled very poorly.

#94661
jamesm2w
Participant

and not communicated about this issue at all.

image
image
image
image
Bossa Response anyone?

#94663
Maximus Villanous
Participant

Thank you for bringing this issue to attention. I have experienced this bug myself about 5-6 times over the past week in the following ways:

-By attacking other ships with cannons and watching it “poof” into nothing.
-I was flying through a stormwall and the ship deleted. (this only happened once out of ten stormwall crossings)
-I was salvaging off an internal power generator and as soon as I finished the whole ship deleted.

#94664
Atreties
Participant

So buried replies on the general text channel of the unofficial discord, mixed in with literally thousands of other messages counts as effective communication to the playerbase to you, @jamesm2w?

No official tweet. No official forum thread. No announcement on discord, nothing on their facebook.

That post says they were able to “find out about the source of the problem”. They know the cause of a gamebreaking bug, but they are not communicating this to their playerbase so that people can avoid situations that would delete their ships.

#94666
Sethodine
Participant

So why don’t we have a ROLLBACK BRANCH!? How is this not hard to get? Next to this ship deletion bug, the other updates from the 1.4.5 hotfix are meaningless. Can’t you just give us a rollback option? This bug has been “tested” and “reproduced” to the abyss and back by now. So why can’t we get a rollback option until a meaningful fix is available? At the very least, this would tell you if the bug was introduced in 1.4.3 or 1.4.5, by rolling us back to 1.4.3 and seeing if it persists.

“This is beta, you are beta testers”

Well back when I did actual beta testing, I was *paid* to reproduce bugs like this. But we’re the ones paying you in this case. It is a social contract; we help you develop your game by paying you early, and you make a game that is playable. We put up with the “work in progress” nature of it, in trade for early access. But this is an obvious problem with a simple temp workaround (rollback), and instead the only update we get after a week is “No more Family Share”. So now I can’t even farm knowledge on my alt to pass the time until a real fix is found.

… I’m going to go read a book.

#94668
Nim Rodelle
Participant

I’ve experienced this issue twice while trying to cross a storm-wall. Clearly Bossa is aware of the situation and is working on a solution. No need to become over-dramatic.

#94670
jamesm2w
Participant

@atreties it is what it is, complain all you like but Bossa are aware and working on a fix. My aim of that message was to make those suffering this aware of the information. Also a simple search “from:herbliu#6370” would have got you that. And by posting it here, I’ve made it infinitely more effective communication for Bossa.

“but hey, they definitely want a game breaking bug in their game.”

#94674
Atreties
Participant

No one has claimed that they want the bug in the game. That’s a silly statement. My complaint is about their lackluster response… as it stated in the title and multiple times in the body of the OP.

#94676
Simayi
Participant

Atreties is right to complain – the communication around this gamebreaking bug has been poor. Atreties shouldn’t have to be the one to start a thread (and Jamesm2w shouldn’t have to be the one replying with discord messages to show Bossa knows) to communicate a bug to the many players who don’t frequent the Discord – it should be Bossa mentioning it on the forum via a pinned message, on their Twitter, and on the Discord via an announcement. Might have saved poor Maximus (and many others) some time and resources.

#94679
Strangecalibur
Participant

I think this happened to me going through a wind wall, the first and only time I have tried. I had 4 okish engines and 2 wings etc, but very early into the attempt I thought I got knocked off the ship….. but I don’t think I did because as far as I was concerned I was at the helm and the ship just dissipated. Been afraid to try ever since, thought my tech just was not good enough.

#94680
Atreties
Participant

People ARE quitting due to this bug, too:
Yup

#94681
Sky Silverwing
Participant

I recommend that people stop playing the game for now until the bug is fixed because that is a really nasty bug. Don’t risk losing your ships and storage loot. I mean, unless you don’t mind running around islands until it’s fixed.

I’m gonna take a break myself until the bug is fixed and hang out more on the forums.

Then again, I’ve been sailing around on my raft and I haven’t encountered this bug. At the same time, I’ve yet to be hit or attacked by mantas or pirates. 😮

#94682
Strangecalibur
Participant

As far as I know there will be a wipe when it goes to open beta, can’t remember where I saw that though so its probably pointless to try and progress at all at the moment.

Viewing 15 posts - 1 through 15 (of 74 total)

You must be logged in to reply to this topic.

Are you sure you want to report this content?

Yes
Add to wishlist button
Bossa Studios logo Improbable logo

Bossa Studios is a multiple award winning independent games developer and publisher happily based in London. We’re the makers of the mega-games Surgeon Simulator, I am Bread and the upcoming MMO Worlds Adrift. Oh, and we’re completely in love with our players (even when they’re angry with us!)

© 2017 Bossa Studios Ltd. Worlds Adrift is a registered trademark of Bossa Studios Ltd. All rights reserved.

EULA – Privacy & Cookies Policy